summaryrefslogtreecommitdiffstats
path: root/package/kismet/kismet.mk
diff options
context:
space:
mode:
authorDaniel Mack <zonque@gmail.com>2011-12-03 18:03:32 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-12-26 08:42:38 +0100
commitf472b915c0b394ba637553da931c5797b07c0b59 (patch)
tree633900e548651ce33e9afd2b590c8775ccf7450a /package/kismet/kismet.mk
parent9c4a7dc9036591a0eaf14eb52f7456657603733f (diff)
downloadbuildroot-novena-f472b915c0b394ba637553da931c5797b07c0b59.tar.gz
buildroot-novena-f472b915c0b394ba637553da931c5797b07c0b59.zip
kismet: fix build with new libnl-3
The CPPFLAGS have to be augmented, so configure finds the correct include dir, and the patch needs to be tweaked to make the binary link to libnl-3 instead of libnl-gen. Signed-off-by: Daniel Mack <zonque@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/kismet/kismet.mk')
-rw-r--r--package/kismet/kismet.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kismet/kismet.mk b/package/kismet/kismet.mk
index 4c7d6e237..854c9dd22 100644
--- a/package/kismet/kismet.mk
+++ b/package/kismet/kismet.mk
@@ -10,6 +10,7 @@ KISMET_DEPENDENCIES = libpcap ncurses
ifeq ($(BR2_PACKAGE_LIBNL),y)
KISMET_DEPENDENCIES += libnl
+ KISMET_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/libnl3/"
endif
ifeq ($(BR2_PACKAGE_PCRE),y)
KISMET_DEPENDENCIES += pcre