summaryrefslogtreecommitdiffstats
path: root/package/dosfstools/dosfstools.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-02-23 21:27:28 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-02-23 21:27:28 +0100
commit4f05a61b33e5d87f23837109fb0dd538a5bd5d62 (patch)
treef1b375060271ec5fd5da6fe89955b11b7c238fae /package/dosfstools/dosfstools.mk
parent52fcd86f2ba1249e74ed04ef39cb3cbea16024c7 (diff)
parentf08e9eea1b70f057cc0a3efa18b2acb4faea4abe (diff)
downloadbuildroot-novena-4f05a61b33e5d87f23837109fb0dd538a5bd5d62.tar.gz
buildroot-novena-4f05a61b33e5d87f23837109fb0dd538a5bd5d62.zip
Merge branch 'misc-fixes5' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'package/dosfstools/dosfstools.mk')
-rw-r--r--package/dosfstools/dosfstools.mk32
1 files changed, 19 insertions, 13 deletions
diff --git a/package/dosfstools/dosfstools.mk b/package/dosfstools/dosfstools.mk
index e1e9fe34e..b826ab183 100644
--- a/package/dosfstools/dosfstools.mk
+++ b/package/dosfstools/dosfstools.mk
@@ -32,7 +32,8 @@ $(DOSFSTOOLS_DIR)/.built : $(DOSFSTOOLS_DIR)/.unpacked
$(STRIPCMD) $(DOSFSTOOLS_DIR)/$(DOSFSLABEL_BINARY)
touch $@
-$(TARGET_DIR)/$(MKDOSFS_TARGET_BINARY): $(DOSFSTOOLS_DIR)/.built
+$(TARGET_DIR)/$(MKDOSFS_TARGET_BINARY): # $(DOSFSTOOLS_DIR)/.built
+ echo foo
cp -a $(DOSFSTOOLS_DIR)/$(MKDOSFS_BINARY) $@
touch -c $@
@@ -44,7 +45,20 @@ $(TARGET_DIR)/$(DOSFSLABEL_TARGET_BINARY): $(DOSFSTOOLS_DIR)/.built
cp -a $(DOSFSTOOLS_DIR)/$(DOSFSLABEL_BINARY) $@
touch -c $@
-dosfstools: $(TARGET_DIR)/$(DOSFSTOOLS_TARGET_BINARY) $(TARGET_DIR)/$(DOSFSCK_TARGET_BINARY)
+DOSFSTOOLS=
+ifeq ($(BR2_PACKAGE_DOSFSTOOLS_MKDOSFS),y)
+DOSFSTOOLS+=$(TARGET_DIR)/$(MKDOSFS_TARGET_BINARY)
+endif
+
+ifeq ($(BR2_PACKAGE_DOSFSTOOLS_DOSFSCK),y)
+DOSFSTOOLS+=$(TARGET_DIR)/$(DOSFSCK_TARGET_BINARY)
+endif
+
+ifeq ($(BR2_PACKAGE_DOSFSTOOLS_DOSFSLABEL),y)
+DOSFSTOOLS+=$(TARGET_DIR)/$(DOSFSLABEL_TARGET_BINARY)
+endif
+
+dosfstools: $(DOSFSTOOLS)
dosfstools-clean:
rm -f $(TARGET_DIR)/$(MKDOSFS_TARGET_BINARY)
@@ -60,14 +74,6 @@ dosfstools-dirclean:
# Toplevel Makefile options
#
#############################################################
-ifeq ($(BR2_PACKAGE_DOSFSTOOLS_MKDOSFS),y)
-TARGETS+=$(TARGET_DIR)/$(MKDOSFS_TARGET_BINARY)
-endif
-
-ifeq ($(BR2_PACKAGE_DOSFSTOOLS_DOSFSCK),y)
-TARGETS+=$(TARGET_DIR)/$(DOSFSCK_TARGET_BINARY)
-endif
-
-ifeq ($(BR2_PACKAGE_DOSFSTOOLS_DOSFSLABEL),y)
-TARGETS+=$(TARGET_DIR)/$(DOSFSLABEL_TARGET_BINARY)
-endif
+ifeq ($(BR2_PACKAGE_DOSFSTOOLS),y)
+TARGETS+=dosfstools
+endif \ No newline at end of file