summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-01-06 16:47:05 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-06 16:47:05 +0100
commit5b33e0b6a139ce3a622817b45a8882a448312fc0 (patch)
treeffad81c8f4163af3bbe7d2b4bde5ee3f177e767e /linux
parentde1eb105a45f88d8c6bf0e00f9b878a36114a5c1 (diff)
downloadbuildroot-novena-5b33e0b6a139ce3a622817b45a8882a448312fc0.tar.gz
buildroot-novena-5b33e0b6a139ce3a622817b45a8882a448312fc0.zip
linux: handle new dtb location since 3.8-rc1 for appended dtbs
Similar to how we've done it for seperate dtbs (ef34705087b). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk11
1 files changed, 9 insertions, 2 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index e852f626f..7ec9cd244 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -203,14 +203,21 @@ endif
ifeq ($(BR2_LINUX_KERNEL_APPENDED_UIMAGE),y)
define LINUX_APPEND_DTB
- cat $(KERNEL_ARCH_PATH)/boot/$(KERNEL_DTS_NAME).dtb >> $(KERNEL_ARCH_PATH)/boot/zImage
+define LINUX_APPEND_DTB
+ # dtbs moved from arch/$ARCH/boot to arch/$ARCH/boot/dts since 3.8-rc1
+ cat $(wildcard $(addprefix $(KERNEL_ARCH_PATH)/boot/,\
+ $(KERNEL_DTS_NAME).dtb dts/$(KERNEL_DTS_NAME).dtb)) \
+ >> $(KERNEL_ARCH_PATH)/boot/zImage
# We need to generate the uImage here after that so that the uImage is
# generated with the right image size.
$(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) uImage
endef
else ifeq ($(BR2_LINUX_KERNEL_APPENDED_ZIMAGE),y)
define LINUX_APPEND_DTB
- cat $(KERNEL_ARCH_PATH)/boot/$(KERNEL_DTS_NAME).dtb >> $(KERNEL_ARCH_PATH)/boot/zImage
+ # dtbs moved from arch/$ARCH/boot to arch/$ARCH/boot/dts since 3.8-rc1
+ cat $(wildcard $(addprefix $(KERNEL_ARCH_PATH)/boot/,\
+ $(KERNEL_DTS_NAME).dtb dts/$(KERNEL_DTS_NAME).dtb)) \
+ >> $(KERNEL_ARCH_PATH)/boot/zImage
endef
endif