summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2013-01-09 12:12:44 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-13 20:39:47 +0100
commit579fea227394db02916d7487762c79a8e76e8748 (patch)
treee4dc66e966e516f621ebf24d1ea05c6b97f6596e /linux
parent6649d6da3f36e973e87d8a73c9618b3215e16253 (diff)
downloadbuildroot-novena-579fea227394db02916d7487762c79a8e76e8748.tar.gz
buildroot-novena-579fea227394db02916d7487762c79a8e76e8748.zip
linux, uboot, mxs-bootlets, barebox: avoid double slash in CUSTOM_TARBALL
Closes #5846 The $(dir ...) function leaves a slash at the end, so that the LINUX_SITE variable for a custom tarball ends in a slash. The DOWNLOAD macro adds another slash between SITE and SOURCE, which results in a double slash in the download URL. Fix this by stripping off the final slash from the _SITE in all packages that have a custom tarball. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 61d4267de..91a9f500b 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -10,7 +10,7 @@ LINUX_LICENSE_FILES = COPYING
# Compute LINUX_SOURCE and LINUX_SITE from the configuration
ifeq ($(LINUX_VERSION),custom)
LINUX_TARBALL = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_TARBALL_LOCATION))
-LINUX_SITE = $(dir $(LINUX_TARBALL))
+LINUX_SITE = $(patsubst %/,%,$(dir $(LINUX_TARBALL)))
LINUX_SOURCE = $(notdir $(LINUX_TARBALL))
else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_GIT),y)
LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_GIT_REPO_URL))