summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2013-01-08 11:23:56 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-09 00:07:56 +0100
commita1cfe20df6c6b4f148db0c104e8ff701654a2c09 (patch)
tree9d109cbd56609752c1be8f9b27be0c7472e5dd0e /linux
parentb0e63e5b9a736e70a24e156033663088b4a7f199 (diff)
downloadbuildroot-novena-a1cfe20df6c6b4f148db0c104e8ff701654a2c09.tar.gz
buildroot-novena-a1cfe20df6c6b4f148db0c104e8ff701654a2c09.zip
linux: fix appended dtb handling of pre/post v3.8-rc1
The $(wildcard ) doesn't work for LINUX_APPEND_DTB, because the .dtb doesn't exist yet at that point. Also factor the common part out. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk27
1 files changed, 12 insertions, 15 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index fe5f738ed..61d4267de 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -201,23 +201,20 @@ endef
endif
endif
-ifeq ($(BR2_LINUX_KERNEL_APPENDED_UIMAGE),y)
-define LINUX_APPEND_DTB
- # dtbs moved from arch/$ARCH/boot to arch/$ARCH/boot/dts since 3.8-rc1
- cat $(wildcard $(addprefix $(KERNEL_ARCH_PATH)/boot/,\
- $(KERNEL_DTS_NAME).dtb dts/$(KERNEL_DTS_NAME).dtb)) \
- >> $(KERNEL_ARCH_PATH)/boot/zImage
- # We need to generate the uImage here after that so that the uImage is
- # generated with the right image size.
- $(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) uImage
-endef
-else ifeq ($(BR2_LINUX_KERNEL_APPENDED_ZIMAGE),y)
+ifeq ($(BR2_LINUX_KERNEL_APPENDED_DTB),y)
+# dtbs moved from arch/$ARCH/boot to arch/$ARCH/boot/dts since 3.8-rc1
define LINUX_APPEND_DTB
- # dtbs moved from arch/$ARCH/boot to arch/$ARCH/boot/dts since 3.8-rc1
- cat $(wildcard $(addprefix $(KERNEL_ARCH_PATH)/boot/,\
- $(KERNEL_DTS_NAME).dtb dts/$(KERNEL_DTS_NAME).dtb)) \
- >> $(KERNEL_ARCH_PATH)/boot/zImage
+ if [ -e $(KERNEL_ARCH_PATH)/boot/$(KERNEL_DTS_NAME).dtb ]; then \
+ cat $(KERNEL_ARCH_PATH)/boot/$(KERNEL_DTS_NAME).dtb; \
+ else \
+ cat $(KERNEL_ARCH_PATH)/boot/dts/$(KERNEL_DTS_NAME).dtb; \
+ fi >> $(KERNEL_ARCH_PATH)/boot/zImage
endef
+ifeq ($(BR2_LINUX_KERNEL_APPENDED_UIMAGE),y)
+# We need to generate the uImage here after that so that the uImage is
+# generated with the right image size.
+LINUX_APPEND_DTB += $(sep)$(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) uImage
+endif
endif
# Compilation. We make sure the kernel gets rebuilt when the