summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-04-15 08:55:53 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-15 08:55:53 +0200
commit0ffdc16e7dc1d286eeda3447e95381f5a309d492 (patch)
tree2808a56d34111eb8dcf4a65ba1707a8b409ae346 /linux
parenta000029dbf2b42e702fa17c441395bf122564773 (diff)
downloadbuildroot-novena-0ffdc16e7dc1d286eeda3447e95381f5a309d492.tar.gz
buildroot-novena-0ffdc16e7dc1d286eeda3447e95381f5a309d492.zip
linux: error out early if user forgot to specify dts name(s)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 2fff2e9ce..d375cf032 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -58,6 +58,11 @@ else ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_DTS),y)
KERNEL_DTS_NAME = $(basename $(notdir $(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH)))
endif
+ifeq ($(BR2_LINUX_KERNEL_DTS_SUPPORT)$(KERNEL_DTS_NAME),y)
+$(error No kernel device tree source specified, check your \
+BR2_LINUX_KERNEL_USE_INTREE_DTS / BR2_LINUX_KERNEL_USE_CUSTOM_DTS settings)
+endif
+
ifeq ($(BR2_LINUX_KERNEL_APPENDED_DTB),y)
ifneq ($(words $(KERNEL_DTS_NAME)),1)
$(error Kernel with appended device tree needs exactly one DTS source.\