summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2012-11-09 13:54:09 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-14 22:53:25 +0100
commitff3391323a2baa8c1238d795ec82701dacb77c6f (patch)
tree74523efbaa01951754bc609cb828eac0d07bc44b /fs
parentbac970e99d751dd58561313a38311962ea0a79f1 (diff)
downloadbuildroot-novena-ff3391323a2baa8c1238d795ec82701dacb77c6f.tar.gz
buildroot-novena-ff3391323a2baa8c1238d795ec82701dacb77c6f.zip
iso9660 fs: use cpio initrd instead of ext2
The ext2 initrd is pretty broken, because it requires an additional root=/dev/ram0 command line parameter, and a /init to mount devtmps that isn't there in out ext2 rootfs. So just use a cpio instead. Note that there is no check if the kernel supports initramfs or the selected compression method. Also removed a bit of dead code in iso9660.mk. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs')
-rw-r--r--fs/iso9660/Config.in2
-rw-r--r--fs/iso9660/iso9660.mk11
2 files changed, 6 insertions, 7 deletions
diff --git a/fs/iso9660/Config.in b/fs/iso9660/Config.in
index 4c00583dc..98ff78b0b 100644
--- a/fs/iso9660/Config.in
+++ b/fs/iso9660/Config.in
@@ -2,7 +2,7 @@ config BR2_TARGET_ROOTFS_ISO9660
bool "iso image"
depends on (BR2_i386 || BR2_x86_64)
depends on BR2_LINUX_KERNEL
- select BR2_TARGET_ROOTFS_EXT2
+ select BR2_TARGET_ROOTFS_CPIO
select BR2_TARGET_GRUB
help
Build a bootable iso9660 image
diff --git a/fs/iso9660/iso9660.mk b/fs/iso9660/iso9660.mk
index f51b6ee86..029c0dd94 100644
--- a/fs/iso9660/iso9660.mk
+++ b/fs/iso9660/iso9660.mk
@@ -9,20 +9,19 @@
ISO9660_TARGET_DIR=$(BUILD_DIR)/iso9660
ISO9660_BOOT_MENU:=$(call qstrip,$(BR2_TARGET_ROOTFS_ISO9660_BOOT_MENU))
-ISO9660_OPTS:=
-ifeq ($(BR2_TARGET_ROOTFS_ISO9660_SQUASH),y)
-ISO9660_OPTS+=-U
-endif
+ISO9660_CPIO_EXT-$(BR2_TARGET_ROOTFS_CPIO_GZIP) = .gz
+ISO9660_CPIO_EXT-$(BR2_TARGET_ROOTFS_CPIO_BZIP2) = .bz2
+ISO9660_CPIO_EXT-$(BR2_TARGET_ROOTFS_CPIO_LZMA) = .lzma
-$(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot linux rootfs-ext2 grub
+$(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot linux rootfs-cpio grub
@$(call MESSAGE,"Generating root filesystem image rootfs.iso9660")
mkdir -p $(ISO9660_TARGET_DIR)
mkdir -p $(ISO9660_TARGET_DIR)/boot/grub
cp $(GRUB_DIR)/stage2/stage2_eltorito $(ISO9660_TARGET_DIR)/boot/grub/
cp $(ISO9660_BOOT_MENU) $(ISO9660_TARGET_DIR)/boot/grub/menu.lst
cp $(LINUX_IMAGE_PATH) $(ISO9660_TARGET_DIR)/kernel
- cp $(BINARIES_DIR)/rootfs.ext2 $(ISO9660_TARGET_DIR)/initrd
+ cp $(BINARIES_DIR)/rootfs.cpio$(ISO9660_CPIO_EXT-y) $(ISO9660_TARGET_DIR)/initrd
# Use fakeroot to pretend all target binaries are owned by root
rm -f $(FAKEROOT_SCRIPT)
echo "chown -R 0:0 $(ISO9660_TARGET_DIR)" >> $(FAKEROOT_SCRIPT)