summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
authorEzequiel Garcia <ezequiel.garcia@free-electrons.com>2013-03-13 02:28:16 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-13 23:09:40 +0100
commit402d1476f7159ab8055ec8b811b4fb5cd78b5609 (patch)
tree118e879f5682c5716629f92422e7e8cd224c22be /fs
parent19d1cfdb25b4a313b8f916ae80da9f60dc134bf5 (diff)
downloadbuildroot-novena-402d1476f7159ab8055ec8b811b4fb5cd78b5609.tar.gz
buildroot-novena-402d1476f7159ab8055ec8b811b4fb5cd78b5609.zip
fs/common.mk: Strip extra whitespace when device table is empty
Since ROOTFS_DEVICE_TABLES is a concatenation of two strings separated by spaces, there will always be a space in it, which means it's never empty. Therefore, when testing for empty, the condition never evaluate to false. The following change fixes this problem; it runs qstrip on the overall combination of the variables, causing the space to be removed if it's the only thing left. Tested-by: Ezequiel Garcia <ezequiel.garcia@free-electrons.com> Signed-off-by: Thomas De Schampheleire <patrickdepinguin+buildroot@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs')
-rw-r--r--fs/common.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 8b5b2f2e8..a0b7b3909 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -33,8 +33,8 @@
FAKEROOT_SCRIPT = $(BUILD_DIR)/_fakeroot.fs
FULL_DEVICE_TABLE = $(BUILD_DIR)/_device_table.txt
-ROOTFS_DEVICE_TABLES = $(call qstrip,$(BR2_ROOTFS_DEVICE_TABLE)) \
- $(call qstrip,$(BR2_ROOTFS_STATIC_DEVICE_TABLE))
+ROOTFS_DEVICE_TABLES = $(call qstrip,$(BR2_ROOTFS_DEVICE_TABLE) \
+ $(BR2_ROOTFS_STATIC_DEVICE_TABLE))
define ROOTFS_TARGET_INTERNAL