summaryrefslogtreecommitdiffstats
path: root/boot
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-04-11 00:16:10 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-11 07:47:54 +0200
commit964f36fe06a9fdd7be4b5b942176454a6cc052e4 (patch)
tree08c414f6e88192bc1951ae668e1951a0cbac339a /boot
parent742d24c68e7b0f931003152ec2e1a3b203f77206 (diff)
downloadbuildroot-novena-964f36fe06a9fdd7be4b5b942176454a6cc052e4.tar.gz
buildroot-novena-964f36fe06a9fdd7be4b5b942176454a6cc052e4.zip
uboot: simplify patch wildcard for BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
To match the logic we have for BR2_LINUX_KERNEL_PATCH. The user has already specified a custom patch directory, so we don't need to be so specific about the what file names we accept, and it becomes quite cumbersome when a custom git version is used. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/Config.in2
-rw-r--r--boot/uboot/uboot.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index bc5ce19da..d377fd198 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -73,7 +73,7 @@ config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
help
If your board requires custom patches, add the path to the
directory containing the patches here. The patches must be
- named uboot-<version>-<something>.patch.
+ named uboot-<something>.patch.
Most users may leave this empty
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index c337e7552..004bdf2bc 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -64,7 +64,7 @@ endef
ifneq ($(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),)
define UBOOT_APPLY_CUSTOM_PATCHES
support/scripts/apply-patches.sh $(@D) $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR) \
- uboot-$(UBOOT_VERSION)-\*.patch
+ uboot-\*.patch
endef
UBOOT_POST_PATCH_HOOKS += UBOOT_APPLY_CUSTOM_PATCHES