summaryrefslogtreecommitdiffstats
path: root/boot
diff options
context:
space:
mode:
authorVivien Didelot <vivien.didelot@savoirfairelinux.com>2012-08-09 14:11:09 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-08-11 20:23:36 +0200
commit80b43964d01d5c84f66497d6295d786ff925c7de (patch)
tree629ca1a2672b1fc2f30e91b627bfb284ecb3decf /boot
parentd27d40b0de526b4d395210067ae36a0513a29a77 (diff)
downloadbuildroot-novena-80b43964d01d5c84f66497d6295d786ff925c7de.tar.gz
buildroot-novena-80b43964d01d5c84f66497d6295d786ff925c7de.zip
u-boot: add AIS target format
Signed-off-by: Vivien Didelot <vivien.didelot@savoirfairelinux.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/Config.in8
-rw-r--r--boot/uboot/uboot.mk3
2 files changed, 11 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index afc2f917a..900fac7fc 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -79,6 +79,14 @@ endif
choice
prompt "U-Boot binary format"
+ default BR2_TARGET_UBOOT_FORMAT_BIN
+
+config BR2_TARGET_UBOOT_FORMAT_AIS
+ bool "u-boot.ais"
+ help
+ AIS (Application Image Script) is a format defined by TI.
+ It is required to load code/data on OMAP-L1 processors.
+ u-boot.ais contains U-Boot with the SPL support.
config BR2_TARGET_UBOOT_FORMAT_BIN
bool "u-boot.bin"
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 9e03d6a61..b61400e05 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -25,6 +25,9 @@ endif
ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
UBOOT_BIN = u-boot.kwb
UBOOT_MAKE_TARGET = $(UBOOT_BIN)
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_AIS),y)
+UBOOT_BIN = u-boot.ais
+UBOOT_MAKE_TARGET = $(UBOOT_BIN)
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_LDR),y)
UBOOT_BIN = u-boot.ldr
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_NAND_BIN),y)