summaryrefslogtreecommitdiffstats
path: root/boot
diff options
context:
space:
mode:
authorGregory Hermant <gregory.hermant@calao-systems.com>2012-11-22 02:35:11 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-10 21:56:54 +0100
commit62b13aea1dadea09cdddf06f2b9673bc927dcc0c (patch)
tree6115dd4d548212998d516a7330e70c0e688773d9 /boot
parent6f62ce55f037da58cc58a31e67b8e18aee3cec98 (diff)
downloadbuildroot-novena-62b13aea1dadea09cdddf06f2b9673bc927dcc0c.tar.gz
buildroot-novena-62b13aea1dadea09cdddf06f2b9673bc927dcc0c.zip
barebox: use the symlink to copy the barebox binary to the images directory
Barebox creates a symlink to the binary. This symlink points to the barebox.bin or to the compressed zbarebox.bin binary. Signed-off-by: Gregory Hermant <gregory.hermant@calao-systems.com> Tested-by: Fabio Porcedda <fabio.porcedda@gmail.com> Acked-by: Fabio Porcedda <fabio.porcedda@gmail.com> Tested-by: Fabio Porcedda <fabio.porcedda@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot')
-rw-r--r--boot/barebox/barebox.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index a025d5f4a..6cc497669 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -72,7 +72,11 @@ define BAREBOX_BUILD_CMDS
endef
define BAREBOX_INSTALL_IMAGES_CMDS
- cp $(@D)/barebox.bin $(BINARIES_DIR)
+ if test -h $(@D)/barebox-flash-image ; then \
+ cp -L $(@D)/barebox-flash-image $(BINARIES_DIR)/barebox.bin ; \
+ else \
+ cp $(@D)/barebox.bin $(BINARIES_DIR);\
+ fi
endef
ifeq ($(BR2_TARGET_BAREBOX_BAREBOXENV),y)