summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@free-electrons.com>2013-05-06 00:14:55 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-06 12:26:06 +0200
commitf59aeca6b48974c98fab28a300efb2980ac21154 (patch)
tree2752bf83eade3e9889161cfb8364829beada6b77 /Makefile
parent2f40b6ae2b27486af2deb999385e3d7f034e4bd5 (diff)
downloadbuildroot-novena-f59aeca6b48974c98fab28a300efb2980ac21154.tar.gz
buildroot-novena-f59aeca6b48974c98fab28a300efb2980ac21154.zip
armv8: Fix defconfig build
Commit 14f48861 ("arc: Add ARC and ARC BE architecture") introduced a sed match against arc* buildroot architecture to translate it to arc. This causes a problem with armv8, which is called in buildroot aarch64, which is also matching, resulting in a build failure. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1692a369c..9128c7579 100644
--- a/Makefile
+++ b/Makefile
@@ -238,7 +238,8 @@ ARCH:=$(call qstrip,$(BR2_ARCH))
KERNEL_ARCH:=$(shell echo "$(ARCH)" | sed -e "s/-.*//" \
-e s/i.86/i386/ -e s/sun4u/sparc64/ \
- -e s/arc.*/arc/ \
+ -e s/arcle/arc/ \
+ -e s/arcbe/arc/ \
-e s/arm.*/arm/ -e s/sa110/arm/ \
-e s/aarch64/arm64/ \
-e s/bfin/blackfin/ \