summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2013-04-08 06:50:16 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-30 22:37:18 +0200
commite9b771283765e74792df6a05775383f6d4da2636 (patch)
tree090490255d8947abc1069b0125a18e64b9a1778b /Makefile
parent92625d742e5eb0eae2094f7890b475aadff9d03e (diff)
downloadbuildroot-novena-e9b771283765e74792df6a05775383f6d4da2636.tar.gz
buildroot-novena-e9b771283765e74792df6a05775383f6d4da2636.zip
rootfs-overlay: use a make foreach instead of a shell for
Makes the code uniform with the post-build and post-image implementation (which is slightly simpler and, presumably, more efficient). Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 840aa1fe9..97804ff78 100644
--- a/Makefile
+++ b/Makefile
@@ -501,13 +501,12 @@ endif
echo "PRETTY_NAME=\"Buildroot $(BR2_VERSION)\"" \
) > $(TARGET_DIR)/etc/os-release
- @for dir in $(call qstrip,$(BR2_ROOTFS_OVERLAY)); do \
- $(call MESSAGE,"Copying overlay $${dir}"); \
+ @$(foreach d, $(call qstrip,$(BR2_ROOTFS_OVERLAY)), \
+ $(call MESSAGE,"Copying overlay $(d)"); \
rsync -a \
--exclude .empty --exclude .svn --exclude .git \
--exclude .hg --exclude '*~' \
- $${dir}/ $(TARGET_DIR); \
- done
+ $(d)/ $(TARGET_DIR)$(sep))
@$(foreach s, $(call qstrip,$(BR2_ROOTFS_POST_BUILD_SCRIPT)), \
$(call MESSAGE,"Executing post-build script $(s)"); \