summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2013-03-06 07:14:26 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-10 21:30:16 +0100
commitdf99efb3d9114aa09153fdb1f47b7ce695e8f53b (patch)
treef6119ab6b7f64138e332f9fe6376495d790becc2 /Makefile
parentbe9e675ae3c10db39b0babe9a8225b572596b2e2 (diff)
downloadbuildroot-novena-df99efb3d9114aa09153fdb1f47b7ce695e8f53b.tar.gz
buildroot-novena-df99efb3d9114aa09153fdb1f47b7ce695e8f53b.zip
CMake packages: remove .cmake files from target directory
Just like pkgconfig files. Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1300725bf..c462bb1d4 100644
--- a/Makefile
+++ b/Makefile
@@ -452,7 +452,9 @@ ifeq ($(BR2_HAVE_DEVFILES),y)
( support/scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )
else
rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/share/aclocal \
- $(TARGET_DIR)/usr/lib/pkgconfig $(TARGET_DIR)/usr/share/pkgconfig
+ $(TARGET_DIR)/usr/lib/pkgconfig $(TARGET_DIR)/usr/share/pkgconfig \
+ $(TARGET_DIR)/usr/lib/cmake $(TARGET_DIR)/usr/share/cmake
+ find $(TARGET_DIR)/usr/{lib,share}/ -name '*.cmake' -print0 | xargs -0 rm -f
find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
endif