summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-12-01 18:10:46 -0800
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-01 18:13:05 -0800
commit8a46d4bf1fe81dc60aca8795d9e2c69a9c252e37 (patch)
tree4acb26cbdab244f875c86a94cc7f156d604b8f6c /Makefile
parent1a59dfae0ce9e93da413285e7c47a16f7317123e (diff)
downloadbuildroot-novena-8a46d4bf1fe81dc60aca8795d9e2c69a9c252e37.tar.gz
buildroot-novena-8a46d4bf1fe81dc60aca8795d9e2c69a9c252e37.zip
{rand,allyes}packageconfig: ensure legacy test options don't get enabled
The legacy BR2_PACKAGE_* options in Config.in.legacy are not supposed to be user selectable, so {rand,allyes}packageconfig shouldn't enable them. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index d3f9b40c8..b394fd54f 100644
--- a/Makefile
+++ b/Makefile
@@ -619,6 +619,9 @@ allnoconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
randpackageconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
@mkdir -p $(BUILD_DIR)/buildroot-config
@grep -v BR2_PACKAGE_ $(CONFIG_DIR)/.config > $(CONFIG_DIR)/.config.nopkg
+ @grep '^config BR2_PACKAGE_' Config.in.legacy | \
+ while read config pkg; do \
+ echo "# $$pkg is not set" >> $(CONFIG_DIR)/.config.nopkg; done
@$(COMMON_CONFIG_ENV) \
KCONFIG_ALLCONFIG=$(CONFIG_DIR)/.config.nopkg \
$< --randconfig $(CONFIG_CONFIG_IN)
@@ -627,6 +630,9 @@ randpackageconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
allyespackageconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
@mkdir -p $(BUILD_DIR)/buildroot-config
@grep -v BR2_PACKAGE_ $(CONFIG_DIR)/.config > $(CONFIG_DIR)/.config.nopkg
+ @grep '^config BR2_PACKAGE_' Config.in.legacy | \
+ while read config pkg; do \
+ echo "# $$pkg is not set" >> $(CONFIG_DIR)/.config.nopkg; done
@$(COMMON_CONFIG_ENV) \
KCONFIG_ALLCONFIG=$(CONFIG_DIR)/.config.nopkg \
$< --allyesconfig $(CONFIG_CONFIG_IN)