summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2013-02-05 07:16:00 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-05 21:35:33 +0100
commit7f86089292e4fa7e6a7b1907611bd007153f452a (patch)
tree822aad879d4707ff0e5f83293a10fc8df92baebe /Makefile
parenta0ad75a1255a742b4e4c95e7becf56b20dfecda3 (diff)
downloadbuildroot-novena-7f86089292e4fa7e6a7b1907611bd007153f452a.tar.gz
buildroot-novena-7f86089292e4fa7e6a7b1907611bd007153f452a.zip
target/generic: add filesystem overlay option
The filesystem overlay is a tree that is copied over the target fs after building everything - which is currently usually done in the post-build script. [Peter: don't ignore missing directories] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 6f8ed0e29..98db8b1ee 100644
--- a/Makefile
+++ b/Makefile
@@ -501,6 +501,13 @@ endif
echo "PRETTY_NAME=\"Buildroot $(BR2_VERSION)\"" \
) > $(TARGET_DIR)/etc/os-release
+ @for dir in $(call qstrip,$(BR2_ROOTFS_OVERLAY)); do \
+ $(call MESSAGE,"Copying overlay $${dir}"); \
+ rsync -a \
+ --exclude .svn --exclude .git --exclude .hg --exclude '*~' \
+ $${dir}/ $(TARGET_DIR); \
+ done
+
ifneq ($(BR2_ROOTFS_POST_BUILD_SCRIPT),"")
@$(call MESSAGE,"Executing post-build script\(s\)")
@$(foreach s, $(call qstrip,$(BR2_ROOTFS_POST_BUILD_SCRIPT)), \