summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2013-04-08 06:50:15 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-24 22:13:44 +0200
commit6d90a69f6c58caff17c1de2f000b65f9bc5a9077 (patch)
tree95ebf2aa8c808486ee2117a77336fd0712b68a2c /Makefile
parent1b9b168562be3466cea2a2e31691c51223a7f88a (diff)
downloadbuildroot-novena-6d90a69f6c58caff17c1de2f000b65f9bc5a9077.tar.gz
buildroot-novena-6d90a69f6c58caff17c1de2f000b65f9bc5a9077.zip
post-image: show each script filename before execution
This also simplifies code by removing the ifneq/endif clauses. Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index e825bcdfa..840aa1fe9 100644
--- a/Makefile
+++ b/Makefile
@@ -555,11 +555,9 @@ target-generatelocales: host-localedef
endif
target-post-image:
-ifneq ($(BR2_ROOTFS_POST_IMAGE_SCRIPT),"")
- @$(call MESSAGE,"Executing post-image script\(s\)")
@$(foreach s, $(call qstrip,$(BR2_ROOTFS_POST_IMAGE_SCRIPT)), \
+ $(call MESSAGE,"Executing post-image script $(s)"); \
$(s) $(BINARIES_DIR)$(sep))
-endif
toolchain-eclipse-register:
./support/scripts/eclipse-register-toolchain `readlink -f $(O)` $(notdir $(TARGET_CROSS)) $(BR2_ARCH)