summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-06-30 21:29:08 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-07-04 09:06:33 +0200
commit12d1aa4b69614f6499847758294f8a40f1611710 (patch)
tree58c1d6e648a149cb40cc88a5727fdee0cb292244 /Makefile
parente57e4b96bf33b5a498608204913d6731a6856b5e (diff)
downloadbuildroot-novena-12d1aa4b69614f6499847758294f8a40f1611710.tar.gz
buildroot-novena-12d1aa4b69614f6499847758294f8a40f1611710.zip
Remove BR2_HAVE_DEVFILES
This finally removes the BR2_HAVE_DEVFILES option, that was used to install/keep development files on target. With the recent migration of the internal backend to the package infrastructure, we had anyway lost the ability to build gcc for the target, and install the uClibc development files on the target. [Peter: also remove support/scripts/copy.sh] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 7a4602c7d..fe9bde729 100644
--- a/Makefile
+++ b/Makefile
@@ -450,16 +450,12 @@ STRIP_FIND_CMD += -type f -perm +111
STRIP_FIND_CMD += -not \( $(call findfileclauses,libpthread*.so* $(call qstrip,$(BR2_STRIP_EXCLUDE_FILES))) \) -print
target-finalize:
-ifeq ($(BR2_HAVE_DEVFILES),y)
- ( support/scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )
-else
rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/share/aclocal \
$(TARGET_DIR)/usr/lib/pkgconfig $(TARGET_DIR)/usr/share/pkgconfig \
$(TARGET_DIR)/usr/lib/cmake $(TARGET_DIR)/usr/share/cmake
find $(TARGET_DIR)/usr/{lib,share}/ -name '*.cmake' -print0 | xargs -0 rm -f
find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
-endif
ifneq ($(BR2_PACKAGE_GDB),y)
rm -rf $(TARGET_DIR)/usr/share/gdb
endif