summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2013-02-07 11:58:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-08 22:11:24 +0100
commitafea3037ef3a6718051e79dd7f7e3bb2e4cc224e (patch)
treed3de43716558ab7eb6ac3c283372a91de9ea9082 /Makefile
parentc482eed74c5238065ab1211c1e094be656fcda4f (diff)
downloadbuildroot-novena-afea3037ef3a6718051e79dd7f7e3bb2e4cc224e.tar.gz
buildroot-novena-afea3037ef3a6718051e79dd7f7e3bb2e4cc224e.zip
rootfs-overlay: also exclude .empty files
This makes it possible to put empty directories in the overlay. Thanks to Aras Vaichas for pointing that out. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 395d270c9..7f0822f15 100644
--- a/Makefile
+++ b/Makefile
@@ -506,7 +506,8 @@ endif
@for dir in $(call qstrip,$(BR2_ROOTFS_OVERLAY)); do \
$(call MESSAGE,"Copying overlay $${dir}"); \
rsync -a \
- --exclude .svn --exclude .git --exclude .hg --exclude '*~' \
+ --exclude .empty --exclude .svn --exclude .git \
+ --exclude .hg --exclude '*~' \
$${dir}/ $(TARGET_DIR); \
done