summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorValentine Barshak <gvaxon@gmail.com>2012-10-02 08:52:15 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-04 23:03:48 +0200
commit94d3aa171cfa72405c51686c82164d5af246f7bd (patch)
tree7bda358eb820972ee56e4bba7b3829ea6c05ca65 /Makefile
parent11017f081fc5b034e680d89eaea729c19f450e01 (diff)
downloadbuildroot-novena-94d3aa171cfa72405c51686c82164d5af246f7bd.tar.gz
buildroot-novena-94d3aa171cfa72405c51686c82164d5af246f7bd.zip
Makefile: Remove more pkgconfig files
The pkgconfig files are located in /usr/lib/pkgconfig and /usr/share/pkgconfig directories. However, only /usr/lib/pkgconfig is removed when no development files are needed in the target filesystem. Remove pkgconfig directory from $(TARGET_DIR)/usr/share as well if BR2_HAVE_DEVFILES is not set. Signed-off-by: Valentine Barshak <gvaxon@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 6536bca9b..0128839e2 100644
--- a/Makefile
+++ b/Makefile
@@ -419,7 +419,8 @@ target-finalize:
ifeq ($(BR2_HAVE_DEVFILES),y)
( support/scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )
else
- rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/lib/pkgconfig $(TARGET_DIR)/usr/share/aclocal
+ rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/share/aclocal \
+ $(TARGET_DIR)/usr/lib/pkgconfig $(TARGET_DIR)/usr/share/pkgconfig
find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
endif