summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-03-30 20:45:42 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-03-30 20:45:42 +0000
commit01c51685795e012b992ee6820016119c807a1d95 (patch)
treeb8731feda8759bc1bb330b97e2f6d84f1f43d350 /Makefile
parent697dd2ed93d57789c38efab1e29d9f7786d27d5b (diff)
downloadbuildroot-novena-01c51685795e012b992ee6820016119c807a1d95.tar.gz
buildroot-novena-01c51685795e012b992ee6820016119c807a1d95.zip
target_skeleton: mark empty directories with .empty files
Mark empty directories in target skeletons with .empty files and remove them while copying to target (like it's already done for svn and cvs files) to better support version control system which don't handle empty directories (E.G. git-svn).
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index bfa6a2fad..31bd1ac76 100644
--- a/Makefile
+++ b/Makefile
@@ -330,6 +330,7 @@ $(PROJECT_BUILD_DIR)/.root:
fi
-find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
-find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
+ -find $(TARGET_DIR) -type d -name .empty | xargs rm -rf
touch $@
$(TARGET_DIR): $(PROJECT_BUILD_DIR)/.root