summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2013-05-15 00:18:35 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-17 11:58:34 +0200
commite5b1da184625d25fe0618ab0a0d5549207f3a64c (patch)
tree67fd4e9dc99d4ed7f52f8c5b21af8b2ca87ff16a
parent0156825d116283109a44315430557cd11f028cef (diff)
downloadbuildroot-novena-e5b1da184625d25fe0618ab0a0d5549207f3a64c.tar.gz
buildroot-novena-e5b1da184625d25fe0618ab0a0d5549207f3a64c.zip
libxml2: depend on zlib and libiconv if appropriate
Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/libxml2/libxml2.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
index 6a974ef8b..7800d946a 100644
--- a/package/libxml2/libxml2.mk
+++ b/package/libxml2/libxml2.mk
@@ -34,6 +34,21 @@ else
HOST_LIBXML2_CONF_OPT += --without-python
endif
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+LIBXML2_DEPENDENCIES += zlib
+LIBXML2_CONF_OPT += --with-zlib
+else
+LIBXML2_CONF_OPT += --without-zlib
+endif
+
+LIBXML2_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+
+ifeq ($(BR2_ENABLE_LOCALE)$(BR2_PACKAGE_LIBICONV),y)
+LIBXML2_CONF_OPT += --with-iconv
+else
+LIBXML2_CONF_OPT += --without-iconv
+endif
+
$(eval $(autotools-package))
$(eval $(host-autotools-package))