summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-05-09 05:53:05 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-12 22:22:18 +0200
commit7c6232658a61c33d4746ace8f479916f957a5a6b (patch)
treea1fcbcace96687ba8ec186b9dd79ebe3733569dc
parent671bd0468516224bf8c1bb56e35bed9b3cb0c8d6 (diff)
downloadbuildroot-novena-7c6232658a61c33d4746ace8f479916f957a5a6b.tar.gz
buildroot-novena-7c6232658a61c33d4746ace8f479916f957a5a6b.zip
toolchain/gcc: the ARC version of gcc needs host-flex/host-bison
For some reason (probably because the ARC changes modify some lex/yacc files without updating their pre-generated variants, or because the date/time of the pre-generated files is not correct), building the ARC gcc requires host-flex and host-bison. We have tested 4.2 for AVR, 4.3 and 4.4 for ARM, and none of those need host-flex or host-bison to be installed, so only the 4.4 for ARC seems to be affected. Fixes the build failure visible at http://autobuild.buildroot.org/results/673c6262e3dde8ee8dd28204d814097e6ba8f8e9/build-end.log. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 8cacc3281..21679ef17 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -180,6 +180,10 @@ endif
GCC_HOST_PREREQ += host-mpc
endif
+ifeq ($(BR2_GCC_VERSION_4_4_7_ARC),y)
+GCC_HOST_PREREQ += host-flex host-bison
+endif
+
ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
GCC_SHARED_LIBGCC:=--enable-shared
else