summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-05-11 04:49:34 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-11 21:52:22 +0200
commit603293f5ff8e2aa95075f03f1044afb1a7c03919 (patch)
treed876cea19123b6590c62c0b884802578527ff0b7
parentd131f75019ed770db7d010a9eefdf1696ad82718 (diff)
downloadbuildroot-novena-603293f5ff8e2aa95075f03f1044afb1a7c03919.tar.gz
buildroot-novena-603293f5ff8e2aa95075f03f1044afb1a7c03919.zip
toolchain-external: fix bug #5054
The external toolchain logic checks (and finds) the proper ARCH_LIB_DIR and forcibly copies it to */lib even if it's in */lib64 This is all well until the check is done for create_lib64_symlinks which only verifies if ARCH_SYSROOT_DIR/lib64 is a symlink, which in some toolchain it's a real directory (like sourcery x86_64 2012.09) and thus doesn't make the symlink in the target. Fix this by also checking for a real directory. Easily reproducible by running "make qemu_x86_64_defconfig", switching to an external toolchain before build, building and then trying to run the resulting image. Closes bug #5054 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES4
-rw-r--r--toolchain/toolchain-external/ext-tool.mk2
2 files changed, 5 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 97f5a4d88..04c1eeddd 100644
--- a/CHANGES
+++ b/CHANGES
@@ -6,6 +6,10 @@
libcurl, pulseaudio, python-nfc, qt5imageformats, strace,
wvstreams
+ Issues resolved (http://bugs.uclibc.org):
+
+ #5054: amd64: cannot find init - due to missing /lib64 folder
+
2013.05-rc1, Released May 8th, 2013:
Architectures: ARC support, Blackfin support, FLAT binary
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index bf2bee868..a87bc3b5a 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -446,7 +446,7 @@ $(STAMP_DIR)/ext-toolchain-installed: $(STAMP_DIR)/ext-toolchain-checked
fi ; \
$(call MESSAGE,"Copying external toolchain sysroot to staging...") ; \
$(call copy_toolchain_sysroot,$${SYSROOT_DIR},$${ARCH_SYSROOT_DIR},$${ARCH_SUBDIR},$${ARCH_LIB_DIR},$${SUPPORT_LIB_DIR}) ; \
- if [ -L $${ARCH_SYSROOT_DIR}/lib64 ] ; then \
+ if [ -L $${ARCH_SYSROOT_DIR}/lib64 -o -d $${ARCH_SYSROOT_DIR}/lib64 ] ; then \
$(call create_lib64_symlinks) ; \
fi ; \
if test x"$(BR2_TOOLCHAIN_EXTERNAL_GDB_SERVER_COPY)" == x"y"; then \