summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2013-05-12 08:31:44 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-12 21:03:40 +0200
commit4624567df1c5e05963ecc0f2a36299a89068ca41 (patch)
tree182a7f3ed9d9c412644902128db3fe929fa831f9
parentd6fa07ffae88c284f41bd5948698a89484c53e10 (diff)
downloadbuildroot-novena-4624567df1c5e05963ecc0f2a36299a89068ca41.tar.gz
buildroot-novena-4624567df1c5e05963ecc0f2a36299a89068ca41.zip
classpath: remove qt support
classpath doesn't work with Qt in buildroot. It assumes qt will run on X11, but we don't have qt-x11 support on buildroot. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/classpath/classpath.mk11
1 files changed, 4 insertions, 7 deletions
diff --git a/package/classpath/classpath.mk b/package/classpath/classpath.mk
index 2d1255261..61a103457 100644
--- a/package/classpath/classpath.mk
+++ b/package/classpath/classpath.mk
@@ -8,6 +8,10 @@ CLASSPATH_CONF_OPT = \
--disable-gconf-peer \
--disable-tools
+# classpath assumes qt runs on top of X11, but we
+# don't support qt4 on X11
+CLASSPATH_CONF_OPT += --disable-qt-peer
+
CLASSPATH_DEPENDENCIES = host-pkgconf
ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
@@ -39,13 +43,6 @@ else
CLASSPATH_CONF_OPT += --disable-gtk-peer --disable-gstreamer-peer
endif
-ifeq ($(BR2_PACKAGE_QT),y)
-CLASSPATH_CONF_OPT += --enable-qt-peer
-CLASSPATH_DEPENDENCIES += qt
-else
-CLASSPATH_CONF_OPT += --disable-qt-peer
-endif
-
ifeq ($(BR2_PACKAGE_LIBXML2)$(BR2_PACKAGE_LIBXSLT),yy)
CLASSPATH_CONF_OPT += --enable-xmlj
CLASSPATH_DEPENDENCIES += libxml2 libxslt