summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2013-05-12 10:05:22 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-12 22:10:28 +0200
commit1c0d1949c69f24518de63921b00130e9ae1082c0 (patch)
treeaf4d4e6ea57ebc846132e067029eea6e990d73ff
parent40ccd2122e003d0c513c65eb389fe5a902ae9108 (diff)
downloadbuildroot-novena-1c0d1949c69f24518de63921b00130e9ae1082c0.tar.gz
buildroot-novena-1c0d1949c69f24518de63921b00130e9ae1082c0.zip
pulseaudio: fix build with orc
The configure script gets orcc from pkg-config, which sets it to /usr/bin/orcc instead of $(HOST_DIR)/usr/bin/orcc. So set the path explicitly instead of relying on pkg-config. While we're at it, also add an explicit enable/disable to configure. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/multimedia/pulseaudio/pulseaudio.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/multimedia/pulseaudio/pulseaudio.mk b/package/multimedia/pulseaudio/pulseaudio.mk
index aa67592d2..b39d99e18 100644
--- a/package/multimedia/pulseaudio/pulseaudio.mk
+++ b/package/multimedia/pulseaudio/pulseaudio.mk
@@ -28,7 +28,6 @@ PULSEAUDIO_DEPENDENCIES = \
$(if $(BR2_PACKAGE_UDEV),udev) \
$(if $(BR2_PACKAGE_OPENSSL),openssl) \
$(if $(BR2_PACKAGE_FFTW),fftw) \
- $(if $(BR2_PACKAGE_ORC),orc) \
$(if $(BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING),webrtc-audio-processing) \
$(if $(BR2_PACKAGE_SYSTEMD),systemd)
@@ -38,6 +37,14 @@ PULSEAUDIO_DEPENDENCIES = \
PULSEAUDIO_AUTORECONF = YES
PULSEAUDIO_DEPENDENCIES += libglib2
+ifeq ($(BR2_PACKAGE_ORC),y)
+PULSEAUDIO_DEPENDENCIES += orc
+PULSEAUDIO_CONF_ENV += ORCC=$(HOST_DIR)/usr/bin/orcc
+PULSEAUDIO_CONF_OPT += --enable-orc
+else
+PULSEAUDIO_CONF_OPT += --disable-orc
+endif
+
ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
# The optional webrtc echo canceller is written in C++, causing auto* to want
# to link module-echo-cancel.so with CXX even if webrtc ISN'T used.