summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgnacy Gawedzki <i@lri.fr>2013-02-07 03:48:35 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-09 10:55:59 +0100
commit5946dcfc582370fa8b55f06517a98bac2b2c1c1e (patch)
treee7564bd538bb95774dce5bd4d9872546bf8cbde2
parent5ff6989445eac9ce59a5041c656bcb0319dce0eb (diff)
downloadbuildroot-novena-5946dcfc582370fa8b55f06517a98bac2b2c1c1e.tar.gz
buildroot-novena-5946dcfc582370fa8b55f06517a98bac2b2c1c1e.zip
boost: Pass staging dir to --with-icu option.
When using the --with-icu option without specifying the directory, boost's bootstrap.sh script will look at "common" locations (lines 289-294): COMMON_ICU_PATHS="/usr /usr/local /sw" for p in $COMMON_ICU_PATHS; do if test -r $p/include/unicode/utypes.h; then ICU_ROOT=$p fi done With buildroot it may surely become problematic at some point. Signed-off-by: Ignacy Gawędzki <i@lri.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/boost/boost.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 5e1bb4e24..a2028484b 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -39,7 +39,7 @@ BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_TIMER),,timer)
BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_WAVE),,wave)
ifeq ($(BR2_PACKAGE_ICU),y)
-BOOST_FLAGS += --with-icu
+BOOST_FLAGS += --with-icu=$(STAGING_DIR)/usr
BOOST_DEPENDENCIES += icu
else
BOOST_FLAGS += --without-icu