summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-10-28 17:40:35 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-02 21:08:50 +0100
commitb90a10303e459dd288d434b27fc1e688ff94afba (patch)
tree4658ac3d28e7a04e7c98815c48b12fd605f05168
parentd27e09a71ae68d141ba6eb0fc64f9eb03a734727 (diff)
downloadbuildroot-novena-b90a10303e459dd288d434b27fc1e688ff94afba.tar.gz
buildroot-novena-b90a10303e459dd288d434b27fc1e688ff94afba.zip
Support KERNEL_ARCH for AArch64
The architecture tuple is 'aarch64', but the kernel people decided to call it 'arm64', so we have to do some mungling to get the kernel architecture name from the Buildroot architecture name. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 0128839e2..dff6aeb2f 100644
--- a/Makefile
+++ b/Makefile
@@ -235,6 +235,7 @@ ARCH:=$(call qstrip,$(BR2_ARCH))
KERNEL_ARCH:=$(shell echo "$(ARCH)" | sed -e "s/-.*//" \
-e s/i.86/i386/ -e s/sun4u/sparc64/ \
-e s/arm.*/arm/ -e s/sa110/arm/ \
+ -e s/aarch64/arm64/ \
-e s/bfin/blackfin/ \
-e s/parisc64/parisc/ \
-e s/powerpc64/powerpc/ \