summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-11-29 23:05:44 -0800
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-29 23:05:44 -0800
commit2b7be2f1de3eec185a720310d418719ccc3f22f2 (patch)
treee664b8b413a8ee251d474d4888f55191a2474fef
parent0f9bad95a08fad5469185628ef91f446ea616d48 (diff)
downloadbuildroot-novena-2b7be2f1de3eec185a720310d418719ccc3f22f2.tar.gz
buildroot-novena-2b7be2f1de3eec185a720310d418719ccc3f22f2.zip
alsa-lib: fix static linking check
Closes #5732 The symbol for static linking is BR2_PREFER_STATIC_LIB. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES4
-rw-r--r--package/alsa-lib/alsa-lib.mk2
2 files changed, 5 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 0da2d77cc..db7b233ed 100644
--- a/CHANGES
+++ b/CHANGES
@@ -8,6 +8,10 @@
cjson, directfb, gdb, hiawatha, lcdproc, libdaemon, libecore,
libhid, libpcap, libusb, linux-fusion, ocf-linux, strace,
+ Issues resolved (http://bugs.uclibc.org):
+
+ #5732: Error : package/alsa-lib/alsa-lib.mk
+
2012.11-rc1, Released November 17th, 2012
Fixes all over the tree and new features.
diff --git a/package/alsa-lib/alsa-lib.mk b/package/alsa-lib/alsa-lib.mk
index daa551d39..eddd3d2f3 100644
--- a/package/alsa-lib/alsa-lib.mk
+++ b/package/alsa-lib/alsa-lib.mk
@@ -17,7 +17,7 @@ ALSA_LIB_CONF_OPT = --with-alsa-devdir=$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_DEVD
--without-versioned
# Can't build with static & shared at the same time (1.0.25+)
-ifeq ($(BR2_PREFER_STATIC),y)
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
ALSA_LIB_CONF_OPT += --enable-shared=no
else
ALSA_LIB_CONF_OPT += --enable-static=no