summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-25 09:44:57 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-25 09:47:01 +0100
commita35d48f984fa7e499292baec85eba6c9fd5bf28c (patch)
treefc59361da74f938f658f4799aae9319d46f5d49d
parentba50538cfa513f7155f9c7fd30df22047f6eb751 (diff)
downloadbuildroot-novena-a35d48f984fa7e499292baec85eba6c9fd5bf28c.tar.gz
buildroot-novena-a35d48f984fa7e499292baec85eba6c9fd5bf28c.zip
gcc on target: add missing definitions for gcc 4.4
Depending on the gcc version, the gcc include and lib directories have changed. We include support for gcc 4.4 by copy/pasting the support for gcc 4.3. Locations don't seem to have changed between 4.3 and 4.4. This allows the syslimits.h fixup to succeed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 6f65cb35f..dcca431db 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -459,6 +459,10 @@ ifeq ($(findstring x4.3,x$(GCC_VERSION)),x4.3)
GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
GCC_INCLUDE_DIR:=include-fixed
endif
+ifeq ($(findstring x4.4,x$(GCC_VERSION)),x4.4)
+GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
+GCC_INCLUDE_DIR:=include-fixed
+endif
$(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
PATH=$(TARGET_PATH) DESTDIR=$(TARGET_DIR) \