summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-11-23 11:42:47 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-11-23 11:42:47 +0100
commita1deb18ba670d84257d9f6fecf579a9787e7449c (patch)
tree2db68e14977a7acebe7b39ffc53c2cc02802f9c7
parent57ea7207bc68d047a7940db69947b776a89d240b (diff)
downloadbuildroot-novena-a1deb18ba670d84257d9f6fecf579a9787e7449c.tar.gz
buildroot-novena-a1deb18ba670d84257d9f6fecf579a9787e7449c.zip
gamin: fix build with !BR2_LARGEFILE and python enabled
Python binding support is broken for cross compilation, disable for now. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES10
-rw-r--r--package/gamin/gamin.mk5
2 files changed, 8 insertions, 7 deletions
diff --git a/CHANGES b/CHANGES
index c4779acb5..5defd0948 100644
--- a/CHANGES
+++ b/CHANGES
@@ -21,11 +21,11 @@
sdl_sound, swfdec, sysstat
Updated/fixed packages: alsamixergui, autoconf, bootutils, busybox,
- gcc, directfb, dnsmasq, e2fsprogs, festival, gstreamer, gst-plugins-bad,
- gst-plugins-base, gst-plugins-good, imagemagick, ipkg, iptables,
- iw, kernel-headers, kismet, libelf, libevent, libglib2, libidn,
- liblockfile, libmad, libpcap, libupnp, libuuid, lighttpd, ltrace,
- lua, lzma, magiccube4d, matchbox, mdadm, nbd, ncftp, ncurses,
+ gcc, directfb, dnsmasq, e2fsprogs, festival, gamin, gstreamer,
+ gst-plugins-bad, gst-plugins-base, gst-plugins-good, imagemagick,
+ ipkg, iptables, iw, kernel-headers, kismet, libelf, libevent, libglib2,
+ libidn, liblockfile, libmad, libpcap, libupnp, libuuid, lighttpd,
+ ltrace, lua, lzma, magiccube4d, matchbox, mdadm, nbd, ncftp, ncurses,
netkittelnet, netsnmp, ntfs-3g, openntp, openssl, php, python, quagga,
radvd, rsync, rubix, samba, sawman, sdl, shared-mime-info, spawn-fcgi,
speech-tools, sqlite, squashfs, synergy, syslinux, target-binutils,
diff --git a/package/gamin/gamin.mk b/package/gamin/gamin.mk
index 90b215a91..1aa5f8be0 100644
--- a/package/gamin/gamin.mk
+++ b/package/gamin/gamin.mk
@@ -12,9 +12,8 @@ GAMIN_INSTALL_TARGET = YES
GAMIN_CONF_OPT = --program-prefix="" --disable-debug
-ifneq ($(BR2_PACKAGE_PYTHON),y)
+# python support broken
GAMIN_CONF_OPT += --without-python
-endif
GAMIN_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
@@ -22,6 +21,8 @@ GAMIN_CONF_ENV = have_abstract_sockets=no
ifneq ($(BR2_LARGEFILE),y)
GAMIN_CONF_ENV += CC="$(TARGET_CC) $(TARGET_CFLAGS) -DNO_LARGEFILE_SOURCE"
+# the above doesn't work with shared config.cache
+GAMIN_USE_CONFIG_CACHE = NO
endif
GAMIN_DEPENDENCIES = libglib2